PDA

View Full Version : Crashing when running created maps



Tech.Know.Guy
17th June 2007, 23:04
Hidden is crashing when i try to run one of my maps that i created. I can create maps and run them fine inside HL2, but when I try to run the map in Hidden, it crashes.

Please help!

I'm recreating the office i work at. My plan is the make a "relaxing" map to play on those Friday afternoons when you just want to shoot your boss without going to jail. :D

-tkg

Isolation
17th June 2007, 23:08
For some reason, maps built recently need to be run under the SDK Base. There's a tutorial on how to change your SteamApp ID around here somewhere, but here's the short-short version.

Make a shortcut to Hidden

Right click, click properties,

Look for C:\Steam\steam.exe -applaunch 220 and change the number to 215.

Load up the game and play your map. It SHOULD work. If not, post a screen/the error message.

Tech.Know.Guy
17th June 2007, 23:22
WOW! I appreciate the quick post, i have already changed the 220 setting. Its pretty strange how it occurring, i can run hidden with other maps fine and play them, but its only when i run one of my maps under a server that i have started when it f's everything up. I have attached a few screenshots of what occurs.

Screenshot one: The game initializes and brings up this screen like normal.
Screenshot two: Two seconds after i click on "OK" to start the round, it crashes and i get the standard windows dialog.

Thanks, its nice to hear from a lady...

-tkg

Isolation
17th June 2007, 23:33
Thanks, its nice to hear from a lady...

Not quite :rolleyes: Believe it or not, the image next to my name is a guy (japanese artists always go overboard on the metrosexual look).

Anyway, the problem is that you probably don't have an info_spectator in the map. It's the entity that gives you the security camera views in-game. Without at least one, the map will always crash on load. Go add one somewhere, point it somewhere good, compile and try again.

Tech.Know.Guy
17th June 2007, 23:46
Jeez, well that sucks. lol. Thanks for the info.

You are brilliant! that fixed the prob.

Enormous Thanks man,

-tkg