PDA

View Full Version : Problem with animated texture / selfillum



scratch
11th January 2007, 20:08
Alright, i thought this is an issue with the server workaround i had to set up so i can test my maps.. but it isn't, just tried it with the latest b5 build, same issue.

I'm using an animated texture for a lamp consisting of three different textures. All those textures got a selfillum map glued to their back in the alpha channel. Thing is, the first texture represents the off state of the lamp, so actually it doesn't need a selfillum map. Since the .vmt setup (see below) doesn't allow different material states per texture i had to improvise and just made a completely black selfillum map for the first texture. Theoretically this should work fine.

The .vmt setup:


"LightmappedGeneric" {
"$baseTexture" "_xyz/light_02"
"$selfillum" 1
// "$bumpmap" "_xyz/light_02_normal"
"$surfaceprop" "glass"
"Proxies"
{
"ToggleTexture"
{
"toggleTextureVar" "$baseTexture"
"toggleTextureFrameNumVar" "$frame"
"toggleTextureShouldWrap" "0"
}
}
}

The animation itself works fine, i can switch through all three textures. The selfillum maps only work correctly for the two "light" textures though, the first one gets lit as in fullbright although its selfillum map should not allow that (also tried with a completely white selfillum map instead.. same result).

Any advice would be appreciated.