View Full Version : How To control the server?

18th June 2006, 11:07
hi all , i have a Dedicated Server on linux , and i cannt control it.

i mean the server works fine. all great.

i added in the server.cfg the command:
rcon_password blabla

and when i am in the game i type in the console : rcon_password blabla
then i want to change map or kick someone so i type rcon map hdn_docks and it says: "unable to .." dont remember :))
anywas i tried to log in through HLSW and when i type the rcon password and i click on Test it says Failed. and i look on the logs:
HLSW ERROR: Connection failed (No connection could be made because the target machine actively refused it. )

so how can i control the server ?? :|

Dead Inside
18th June 2006, 11:19
Both should work so all i can suggest is make sure the passwords match, make sure there aren't any extra spaces (carriage returns added by crappy editors for example, if you vi server.cfg and look for any ^M in it and remove those just to be sure. (i use "cat filename | col -b | newfilename" to strip them out when required.)

If you don't already then putting quotes around the password might help end it properly and avoid nasty space issues - i.e. rcon_password "password"

I can't remember offhand but theres possibly a seperate port for rcon commands to be sent via you may need to open, i'll see if i can find that. Maybe 27020 from memory.

Edit: nevermind rcon is just through the same port as server, the full advised list i was thinking of is below, but if the server is working ok you can probably just ignore this bit!

UDP 1200 (Friends Network)
UDP 27000 to 27015 (Gameport)
UDP 27020
TCP 27030 to 27039
TCP: 27015 (SRCDS Rcon port)

18th June 2006, 11:30
THank you for your answer.
About what you said with the spaces in the server.cfg its ok.
there are no spaces or ^M. i double checked that.

i have alot of CS servers running on my linux box.
there are some CSS servers too.
the rcon is working ok with all servers.

only in the Hidden server there is the problem with the rcon.

i thought maybe if i will install Mani admin , maybe it could help.
dont you think ?

but i will try now to use the quotes as you said. like rcon_password "blabla".

but still i dont get it why my cSS servers are ok and the hidden is kinda F*cked up.

Dead Inside
18th June 2006, 11:50
Strange, i've never noticed a problem with it at all, i can't think of anything else to suggest really :/

Be careful with what version of mani you install, check out the other threads in the forum about it, the latest beta versions seem to have problems but i think possibly the stable ones are ok. Theres also the combo of sourcemetamod plugins BAT and ForgiveTK. I believe they have been updated since i last used (and had problems) with them, if the bugs have been ironed out that combo could be very good, although it lacks some features of mani.

Installing a seperate admin plugin might give you some control, i'd always preffer full rcon though, i love my HLSW. Perhaps someone else can think of something i've missed.

1st August 2006, 10:25
I can't seem to get rcon to work on my server via LAN or WAN.

If I log onto the server via Putty and type rcon_password it come back with
"rcon_password" = "Bla Bla Bla" ( def. "" )
- remote console password.

I then join the hidden server via steam, and drop the console and type
rcon_password Bla Bla Bla

rcon say hello
Unable to connect to remote server (xx.xxx.xxx.xx:27015)

I have tryied opening all ports on my routers and have even setup DMZ on my routers and still no go.

Is there anything you need to setup 1st for rcon to work?

1st August 2006, 11:10
the RCON port is the same as the game port only thru TCP instead of UDP so you'll need to forward both 27015 UDP for the game port and and 27015 TCP for rcon access.

from there the easiest way to set it up is to have the server's server.cfg have rcon_password "WHATEVER" and then copy and paste that line into your client's autoexec.cfg. that way there's no guess work and possible typos.

if you can't remember the rest of the "unable to..." message then try it again an write it down because without that error message helping you is pointless.

the command you want is rcon changelevel map_name btw so it doesn't kick everyone in the server when the map changes.

2nd August 2006, 09:56
I think I have sorted it now, I did not have the IP address in the startup string, seems to be working now.