PDA

View Full Version : Running Hidden:Source with HL2DM



SkaveRat
31st May 2006, 18:28
Running The Hidden: Source with Half-Life²: DeathMatch:

Update 12.11.06
Thanks to Paegus for the batch file. It's worth a try ;)
http://forum.hidden-source.com/showpost.php?p=96995&postcount=71

Update 11.10.06: Thanks to Source SDK Base it's even simpler to run Hidden: Source:
http://forum.hidden-source.com/showpost.php?p=91655&postcount=60

Update - 15.9.06: Easier way to run H:S with HL2DM: http://forum.hidden-source.com/showpost.php?p=89311&postcount=55


1. Open your Steam folder.
http://img226.imageshack.us/img226/2005/tut12im.jpg (http://imageshack.us)

2. Make a shortcut of the steam.exe
[Right-click -> create shortcut]
http://img153.imageshack.us/img153/2083/tut23br.jpg (http://imageshack.us)

2b. Rename the shortcut (optional)
http://img226.imageshack.us/img226/6932/tut32tw.jpg (http://imageshack.us)

3. Open the shortcut properties
[Right-click -> Properties]
http://img153.imageshack.us/img153/934/tut47gc.jpg (http://imageshack.us)

4.
A funny little window like this one should pop up:
http://img204.imageshack.us/img204/341/tut89rd.jpg (http://imageshack.us)

Add this to the existing target-path:

-applaunch 320
It should look like:
http://img153.imageshack.us/img153/4029/tut57qp.jpg (http://imageshack.us)

Now it's getting a bit complicated.

You have to add following path with your Steam-path.

-game "YOURSTEAMPATH\SteamApps\SourceMods\hidden"
i.e.:
-game "C:\Program Files\Valve\Steam\SteamApps\SourceMods\hidden"
Hint: You can see your Steam path here:
http://img226.imageshack.us/img226/6610/tut75do.jpg (http://imageshack.us)

The "target"-path now should look like:

C:\Programme\Steam\steam.exe -applaunch 320 -game "C:\Programme\Steam\SteamApps\SourceMods\hidden"
This is only an example! Don't use the path above!

5. Click OK

6. Execute the shortcut

7. Have fun gaming ;)

P.S.: Works afaik with all mods. Just change "...\SourceMods\MODFOLDER" to the mods' folder

Too complicated?
Try this one:

You can also start Hidden:Source with HL2DM per Xfire.
Just follow this tutorial:
http://forum.hidden-source.com/showthread.php?t=4999

Ging
16th June 2006, 01:48
Stickied, in the vain, vain hope that people may bloody well read it instead of asking...

ZiBi_pl
17th June 2006, 12:57
hello.
I have steam witch
-CS:SOURCe
-DOD:SOURCE
-HL2 DM

I Add a shortcut into my desktop but game dont run. I have error and game dont run :( Plizz help me.

http://img164.imageshack.us/img164/179/error0hp.jpg

ps. Sorry for my bad Eng

SkaveRat
17th June 2006, 13:59
hello.
I have steam witch
-CS:SOURCe
-DOD:SOURCE
-HL2 DM

I Add a shortcut into my desktop but game dont run. I have error and game dont run :( Plizz help me.

http://img164.imageshack.us/img164/179/error0hp.jpg

ps. Sorry for my bad Eng
could you translate the errormessage?

But I don't think it has somethink to do with the shortcut/HL2DM

ZiBi_pl
17th June 2006, 14:32
Its say
" Instuctions in 0x0d15ebf" is in memory in adres 0x00000. Memory cant be read
Press button OK for stop aplications
Press button Anuluj for start debug"

Some like this ;] Possilbe is this game not work when i have only HL2 DM for muliplayer dod:s and cs:s , not HL2 full ?

SkaveRat
17th June 2006, 14:36
Please run HL2DM at least 1 time. Start it, let it load, maybe play a round, and then quit.
Maybe it will work.


Possilbe is this game not work when i have only HL2 DM for muliplayer dod:s and cs:s , not HL2 full ?
This threat shows how you can play Hidden even, without HL2 full ;)

ZiBi_pl
17th June 2006, 15:01
ok now its working :D thx man :D
I have bad command line in icon :P sorry for wast you time ;) nex time i must better look what i doing :P

CalmLikeABomb
25th June 2006, 16:01
after going into the "properties" on the link i made. you say to redirect this to be
C:\Program Files\Valve\Steam\steam.exe -applaunch 320 -game "c:\Program Files\Valve\steam\SteamApps\SourceMods\hidden" but my problem is i do not have a valve folder or a source mods folder. i think what the problem is would be that the file allocation has changed drastically since yo made this post so if it is at all possible to make a new post that is updated so i can follow it a little bit easier that would be great thanx.

SkaveRat
25th June 2006, 16:27
lol. nothing has changed in 1 month ;)

everything is up to date, problem is, that you haven't changed the path to your Steam folder ;)

Please read the WHOLE post:

(Change the bold parts to your Steam path)

Help me
25th June 2006, 22:36
Ok guys, I need some help. The hidden thing won't go onto my steam games list and I can't make a shortcut for the game.

I followed the tut, but whenever I try to click "ok" on my properties for the shortcut it comes up with this:
http://img59.imageshack.us/img59/7283/untitled4hl.png

for every part of the target code. I'm so close, yet so far.



If you could help me by either getting it on the games list or getting this to work, that would be great.

hutch
25th June 2006, 22:39
Ok guys, I need some help. The hidden thing won't go onto my steam games list and I can't make a shortcut for the game.

I followed the tut, but whenever I try to click "ok" on my properties for the shortcut it comes up with this:
http://img59.imageshack.us/img59/7283/untitled4hl.png

for every part of the target code. I'm so close, yet so far.



If you could help me by either getting it on the games list or getting this to work, that would be great.
the " is messed up in the target path.
:p

Help me
25th June 2006, 23:16
the " is messed up in the target path.
:p
I had a feeling something was wrong with that.

But I don't know how to fix it?! Can't you just copy and paste the code on the front page? Or do I have to edit it?

Note: the code on the front page follows the same way my steam folders go.

hutch
25th June 2006, 23:25
should be able to just copypast it.

Help me
25th June 2006, 23:47
should be able to just copypast it.
That's what I was doing when I got the error message.

Something is amiss, but I don't know what.

SkaveRat
26th June 2006, 09:44
You can copy'n'paste the path in the tutorial, but you need to change the bold parts to your steam path. It should work then

SkaveRat
26th June 2006, 11:12
I've made a complete new tutorial.

Try it now. It should be easier now...

Help me
26th June 2006, 16:50
You can copy'n'paste the path in the tutorial, but you need to change the bold parts to your steam path. It should work then
I did copy'n'paste it and the steam path is exactly the same as mine.

I'm getting pissed now. I'm getting the same popup message as before. I can't even play the game. HELP ME!

Edit: Ok. Now I've narrowed down what part of the code doesn't work. The first part of the code was ok, but when I added the "-applaunch 320" and the rest of it and clicked apply, it didn't work. What does that mean?

SkaveRat
26th June 2006, 17:11
you have a space between
[...]\steam.exe -applaunch 320 -game [...]
?

Else try the new tutorial

Help me
26th June 2006, 17:29
you have a space between
[...]\steam.exe -applaunch 320 -game [...]
?

Else try the new tutorial
Does that mean I sould take the spaces out? Well, I tried to take them out and it still didn't work.

And I tried the example code only tweeked to my english version, which still didn't work.

SkaveRat
26th June 2006, 18:51
the spaces must be there.

Tty the new tutorial from the beginning. I've tested it with some ppl, and it worked everytime

Dark Soul
26th June 2006, 18:57
Hey,dose this work if i have HL:DM source and i want to play a HL1 mod ?

SkaveRat
26th June 2006, 19:05
Hey,dose this work if i have HL:DM source and i want to play a HL1 mod ?

ähm... wait one moment...
*gets a bit baseballbat*
*slap*
so...

Dark Soul
26th June 2006, 19:07
HUh ?

Dark Soul
27th June 2006, 00:59
Dang,i dont think it works with HL : DM Source.It gives me an error with the hl2.exe,i dont even know y its loading hl2 up when its a hl1 game.Any way this is the code i put into the shortcut.

"C:\Program Files\Valve\Steam\Steam.exe" -applaunch 360 -game "C:\Program Files\Valve\Steam\SteamApps\SourceMods\ns"

SkaveRat
27th June 2006, 09:20
well, I don't think so, because it is still HL1(!) DM. all the data of HL2 is missing.

And if -applaunch 360 is the shortcut for HL1:DM Source, the path above should be right

Ging
27th June 2006, 10:38
It won't work...

Wrong engine for one thing, anything from HL1 that's running on Source is, in effect, a Source mod - which is why it's throws the error about the hl2 executable.

Shinobi
27th June 2006, 16:43
Ok, I also tried doing that tutorial on how to run the game, but that doesn't even work for me.

I downloaded both the beta 4 full and its update. When I install it, it doesnt work. It doesn't even show up in "My Games" on steam! Very frustrating...

Could some one help?

Ging
27th June 2006, 19:34
Do you have single player HL2? If so, have you restarted steam?

Freak95
2nd July 2006, 04:40
Okay, tried what the tutorial said, and now I don't have any of the games on Steam for play. They all say not installed now...after I paid for them. What do I need to do now?

SkaveRat
2nd July 2006, 14:23
Okay, tried what the tutorial said, and now I don't have any of the games on Steam for play. They all say not installed now...after I paid for them. What do I need to do now?
install them o.O

Red
4th July 2006, 17:23
I am having this problem:

http://img470.imageshack.us/img470/425/untitled9nk2.jpg

I have read around, tried playing HL2: DM first, and that does not help.

I also tried the tutorial you have on here and seem to be running into some problems that I don't believe are my own fault. It says the file paths are invalid even though I'm right there staring them in the face. :confused: The shortcut I created just leads me to HL2: DM...

Target: "C:\Program Files\Valve\Steam\Steam.exe" -applaunch 320 -game

Start in: " -game "C:\Program Files\Valve\Steam\SteamApps\*******@hotmail.com\hi dden"

I also noticed that whenever I try to start The Hidden via Steam, the HL2 start screen shows up before it crashes. The one at the beginning map where Combine Police and camera bots go in and out of.... that supposed to happen?

Thanks for reading and helping, sorry if I'm wordy, just dying to play this mod.
-Red

BoxyEdit: Probably best not to throw your hotmail address around, you never know what unscrupolous people/bots get in here...

Dr.SharK
4th July 2006, 18:20
Update your graphics card drivers, make sure your ram is not faulty (search google)

"Memory could not be read" is an ancient crash, and the best fix is to stay updated! :)

-Dr.SharK

SkaveRat
4th July 2006, 19:55
Target: "C:\Program Files\Valve\Steam\Steam.exe" -applaunch 320 -game

Start in: " -game "C:\Program Files\Valve\Steam\SteamApps\*******@hotmail.com\hi dden"

That's wrong. Check out the tutorial to see how it should be.
Hidden is not in your Accountname-folder. It's in the "SourceMods"-folder

It should work if you chance your "Target" to:

C:\Program Files\Valve\Steam\Steam.exe -applaunch 320 -game "C:\Program Files\Valve\Steam\SteamApps\SourceMods\hidden"

And delete the content of "Start in"

Red
4th July 2006, 21:02
Reinstalled from scratch and works fine.

Tho it crashed once, something about an overload.

Thanks anyway!

Lt_Jesus
20th July 2006, 00:38
thanks a lot man, this thing ables me to play this awesome game now :)

ThunderDan
22nd July 2006, 13:21
Could comeone who has HL2DM and is running hidden off a shortcut try editting the GameInfo.txt file in the hidden directory to read

SteamAppId 320
You would just change that number from the default 220 to 320.

I think this will make it show up in steam after restarting steam of course, and you wouldn't need to use a shortcut.

Jam06
25th July 2006, 21:42
Gah can someone tell me why this won't work please..


"C:\Program Files\valve\Steam\steam.exe -applaunch 320 -game C:\Program Files\Valve\Steam\SteamApps\SourceMods\hidden"

SkaveRat
26th July 2006, 00:37
Gah can someone tell me why this won't work please..


"C:\Program Files\valve\Steam\steam.exe -applaunch 320 -game C:\Program Files\Valve\Steam\SteamApps\SourceMods\hidden"

put the " from the beginning after the "-game"
here:

C:\Program Files\valve\Steam\steam.exe -applaunch 320 -game "C:\Program Files\Valve\Steam\SteamApps\SourceMods\hidden"
should work

@Dan - I'll test it - If it works, I'll make a tutorial

€dit: doesn't work - too bad :/

BattleDwarf
31st July 2006, 11:35
Could comeone who has HL2DM and is running hidden off a shortcut try editting the GameInfo.txt file in the hidden directory to read

You would just change that number from the default 220 to 320.

I think this will make it show up in steam after restarting steam of course, and you wouldn't need to use a shortcut.

I have HL2 DM only and the shortcut launch of The Hidden works just fine. But I'd like to have The Hidden in my Steam GUI and tried the described method. It didn't work. After restarting Steam the Game List showed the same games as before...
What does the part "-applaunch 320" do anyway? Is it a different ID for other mods?

Thanks for the tut, it worked for me :)

BattleDwarf

shen10
1st August 2006, 02:41
Yaaay im helping
Program Files is 2 words so you have to put the whole location of the file in quotes !!!! dont forget that

shen10
1st August 2006, 19:05
I keep getting this error message when trying to start the game through HL2DM

hl2.exe has generated errors and will be closed by windows. You will need to restart the program.

An error log is being created.

OK

This isnt a very specific error.... but if anyone else has had this problem and fixed it please tell me how. I am attempting to run the game with a desktop shortcut to HL2:DM with lots of tags in the target string that I dont really understand

"C:\Program Files\Steam\steam.exe" -applaunch 320 -game hidden

if theres something wrong there can someone point it out ?

SkaveRat
2nd August 2006, 10:53
I keep getting this error message when trying to start the game through HL2DM

hl2.exe has generated errors and will be closed by windows. You will need to restart the program.

An error log is being created.

OK

This isnt a very specific error.... but if anyone else has had this problem and fixed it please tell me how. I am attempting to run the game with a desktop shortcut to HL2:DM with lots of tags in the target string that I dont really understand

"C:\Program Files\Steam\steam.exe" -applaunch 320 -game hidden

if theres something wrong there can someone point it out ?

please follow the whole tutorial - then it works

this should be your correct string:


C:\Program Files\Steam\steam.exe -applaunch 320 -game "C:\Program Files\Steam\SteamApps\SourceMods\hidden"

go0sebumpz
2nd August 2006, 21:48
how do you run it w/o hl2 deathmatch?

Isolation
2nd August 2006, 21:50
You don't. If you don't have HL2 or HL2DM, you can't play H:S.

Sgt. Duffy
28th August 2006, 15:00
when I put in the -game part I missed it the first time I installed it but then it gave me this The folder '-game D:\Steam\SteamApps\SourceMods\hidden' specified in the start box is not valid. make sure the folder exists and the path is correct. can someone help me? I really want to play this mod cus it looks freaking sweet

The.ViruS
28th August 2006, 15:27
-game "D:\Steam\Steam Apps\Source Mods\hidden"

I think, make sure its in quotes.

Sgt. Duffy
28th August 2006, 16:19
o cool thanks

Sgt. Duffy
28th August 2006, 16:22
nope still doesn't work it still give me a message saying that the info in the starter box isn't valid and that I should check if its right and the path is correct god damn -.- I really wanna try this mod Iheard from some friends that its rocks

SkaveRat
28th August 2006, 16:50
-game "D:\Steam\SteamApps\Source Mods\hidden"

should work - there was a space in the "SteamApps"

Sgt. Duffy
28th August 2006, 16:58
I freaking hate installing things I placed it in both the target and steam paths but it still says that its invalid and all that crap this is soooo fucking gay how I cant play it... do you think it something wrong with the version I got?

SkaveRat
29th August 2006, 13:00
AW MAN!
I hate this board with it's stupid random spaces.
This is your real location:


-game "D:\Steam\SteamApps\SourceMods\hidden"

.12.E.12.E.L.
13th September 2006, 00:13
not working, i followed the tut perfectly and i still cant make the game work...
I also dont have a source mods folder

if it helps these are the following games i have

counter strike source
hl2dm
source forts
DoDs

SkaveRat
13th September 2006, 13:31
not working, i followed the tut perfectly and i still cant make the game work...
I also dont have a source mods folder

if it helps these are the following games i have

counter strike source
hl2dm
source forts
DoDs
how can you run SourceForts?

.12.E.12.E.L.
13th September 2006, 18:51
i folowed this tutorial


This HL2:DM Only installation help applies to Sourceforts v1.9.2

FictiousWill wrote:
Normally the installer creates a folder called 'sourceforts' in the sourcemods directory. It's different for HL2DM-only, but you need to get ahold of that 'sourceforts' directory anyway, you just put it in a different place. Run the installer and see where it extracts to, so you can find this folder. Once you find the sourceforts folder, move it to:

SteamApps/username/half-life 2 deathmatch/

so the full path will be:
SteamApps/username/half-life 2 deathmatch/sourceforts

Now look in SteamApps/username/half-life 2 deathmatch/ and you should find hl2.exe. Right-click on it and choose 'create shortcut'. Go to the properties of the shortcut you just created and find where it displays the 'target' path. You'll need to add

-game sourceforts

to the end of this line, so it reads
"SteamApps/username/half-life 2 deathmatch/hl2.exe" -game sourceforts

Click Apply, then Ok. Then rename the shortcut to 'Sourceforts 1.9.2' and copy it to your desktop. When you run the shortcut, sourceforts should launch normally.


this is not from me -------http://www.sourcefortsmod.com/boards/viewtopic.php?t=3857

.12.E.12.E.L.
13th September 2006, 21:32
o and by the way: this tutorial works better than the other one and it is simpler (in my opinion....no offence) (i am reposting and changing it to the way i did it....it is not my actual tutorial----------->

Normally the installer creates a folder called 'hidden' in the sourcemods directory. It's different for HL2DM-only, but you need to get ahold of that 'hidden' directory anyway, you just put it in a different place. Run the installer and see where it extracts to, so you can find this folder. Once you find the hidden folder, move it to:

SteamApps/username/half-life 2 deathmatch/

so the full path will be:
SteamApps/username/half-life 2 deathmatch/hidden

Now look in SteamApps/username/half-life 2 deathmatch/ and you should find hl2.exe. Right-click on it and choose 'create shortcut'. Go to the properties of the shortcut you just created and find where it displays the 'target' path. You'll need to add

-game hidden

to the end of this line, so it reads
"SteamApps/username/half-life 2 deathmatch/hl2.exe" -game hidden

Click Apply, then Ok. Then rename the shortcut to "The Hidden" and copy it to your desktop. When you run the shortcut, hidden should launch normally.

the real tutorial is from---> http://www.sourcefortsmod.com/boards/viewtopic.php?t=3857

SkaveRat
13th September 2006, 23:17
jepp, thx. didn't know that it could work that way.

I'll update my current tutorial tomorrow

devilarg
1st October 2006, 18:49
Hi!
I have a question, i have CS:S, and no other game of valve, i can play hidden?
I install the gane in the folder sourcemods, but when i run the steam, hidden is not there! :S
Sorry my inglish, im from Argentina! Thanks see you!

hutch
1st October 2006, 19:25
Nope, without HL2 or HL2DM there is no way you can play this mod.
Sorry

Paegus
4th October 2006, 13:14
have you tried ..\path\to\Steam\steam.exe -applaunch 240 -game "...\path\to\steam\SteamApps\SourceMods\hidden"?

the only downside is HL2 specific stuff may not be accessible to you. so you may get ERROR models and missing textures here and there...

SkaveRat
4th October 2006, 15:58
A new tutorial. Try this:

Install the "Source SDK Base". (View->Tools)
You get SDK base as soon you've bought an Source game (so it should work with CS:S, HL2: DM, DoD:S etc)

Then open up the "hidden" folder. Open the "gameinfo.txt" with the text Editor (not MS Word etc ;))

On line 21 you'll find following text:

SteamAppId 220 // This...

just change the "220" into a "215". Restart Steam, and have fun playing ;)

...

If you become a Hidden-pro and earn money with it, always keep in mind, that I told you how to run it :D :rolleyes:

ll4m4
21st October 2006, 21:19
A new tutorial. Try this:

Install the "Source SDK Base". (View->Tools)
You get SDK base as soon you've bought an Source game (so it should work with CS:S, HL2: DM, DoD:S etc)

Then open up the "hidden" folder. Open the "gameinfo.txt" with the text Editor (not MS Word etc ;))

On line 21 you'll find following text:

SteamAppId 220 // This...

just change the "220" into a "215". Restart Steam, and have fun playing ;)

...

If you become a Hidden-pro and earn money with it, always keep in mind, that I told you how to run it :D :rolleyes:

I did that, but what do I do to start the hidden, I've tried starting SDK Base and it when it starts, it takes me to hl2:lost coast screen my options are, Video stress test. quit, options. PLEASE HELP.

ll4m4
21st October 2006, 21:25
what is Wrong with this target path?!!??!


"C:\Program Files\Valve\Steam\steam.exe" -applaunch 320 -game "C:\Program Files\Valve\Steam"

Paegus
21st October 2006, 21:27
what is Wrong with this target path?!!??!
something to do with the fact that your -game path doesn't point anywhere meaningful?

read the first post in the thread...

Isolation
21st October 2006, 23:51
Uh... Source SDK base? H:S does not use that yet... I can't see how or why it'd work...

Fluffy
22nd October 2006, 00:25
Uh... Source SDK base? H:S does not use that yet... I can't see how or why it'd work...

as a matter of fact it does. EVERY steam game that used to run the hl2.exe has been updated to run the new and "improved" Source SDK base. that's why you see "preparing to launch: source SDK base" when you start up hidden...

Paegus
22nd October 2006, 00:30
you only see that if you edit your gameinfo file. as far as i'm aware the current hidden release still uses 220 (hl2). the sdkbase (215) crashes a lot for me anyway so i don't use it.

most servers however use 215 since it has VAC support for 3rd party mods.

Isolation
22nd October 2006, 00:36
Ah, I see. My shortcut says 220, only the hiddenite builds ever loaded using the SDK base. Well, you learn something everyday...

ll4m4
22nd October 2006, 19:22
i got it to work using the hl2.exe tut.

R1pp3
27th October 2006, 21:52
A new tutorial. Try this:

Install the "Source SDK Base". (View->Tools)
You get SDK base as soon you've bought an Source game (so it should work with CS:S, HL2: DM, DoD:S etc)

Then open up the "hidden" folder. Open the "gameinfo.txt" with the text Editor (not MS Word etc ;))

On line 21 you'll find following text:

SteamAppId 220 // This...

just change the "220" into a "215". Restart Steam, and have fun playing ;)

...

If you become a Hidden-pro and earn money with it, always keep in mind, that I told you how to run it :D :rolleyes:
THANK YOU MY LORD!!! <33 i love u Finally hidden works :D

SkaveRat
29th October 2006, 01:41
THANK YOU MY LORD!!! <33 i love u Finally hidden works :D
no problem


(send money donations to Paypal@pwc-clan.de ;))

Paegus
11th November 2006, 14:28
found this batch file i made a while back for use on a USB stick drive i took to a lan party... just drop it in the installed hidden folder and either run directly or make a desktop shortcut to it... should work if you have source sdk base, half-life 2, half-life 2 deathmatch, half-life 2 lostcoast, counter-strike source or day of defeat source installed... in that order of preference.

i don't know the folder name for half-life source so you're on your own if that's all you own.

e: removed code because apparently it confuses people...

e: Updated 2007/02/26: now checks to see if the mod is installed in the SourceMods folder instead of assuming the Source SDK is installed. also you can now drag and drop mod folders onto the batch file.

DUCKVILLE/LOL
14th January 2007, 10:56
A new tutorial. Try this:

Install the "Source SDK Base". (View->Tools)
You get SDK base as soon you've bought an Source game (so it should work with CS:S, HL2: DM, DoD:S etc)

Then open up the "hidden" folder. Open the "gameinfo.txt" with the text Editor (not MS Word etc ;))

On line 21 you'll find following text:

SteamAppId 220 // This...

just change the "220" into a "215". Restart Steam, and have fun playing ;)

...

If you become a Hidden-pro and earn money with it, always keep in mind, that I told you how to run it :D :rolleyes:

May I ask what this actually does? Eg would it work for other mods?

SkaveRat
22nd January 2007, 02:07
May I ask what this actually does? Eg would it work for other mods?
It runs the mod with the "Source SDK Base" instead of HL2.
And it -should- work with other mods (newer mods have changed their AppId to 215 btw)

DUCKVILLE/LOL
7th February 2007, 07:06
Sweet, thank you :)

asskicker
9th March 2007, 18:13
My friend is getting this error :

http://img152.imageshack.us/img152/8306/tssssqq0.png

Tried all of em

Paegus
6th May 2007, 10:41
looks like it's loading HL2 instead of hidden so did he install the game itself or just an update?

Sabber
31st May 2007, 14:41
Hi there,
my friend has a problem to run Hidden with Hl&#178; dm.
Every time he Start the shortcut he become this message

Half-life 2 is required to run mods
Shortcut path ist

D:\Programme\Steam\steam.exe -applaunch 320 -game "D:\Programme\Steam\SteamApps\SourceMods\hidden
The blank in the word hidden is a forum problem
So has anyone an idea what the problem is ? Sorry for my waste english.

Sabber

SkaveRat
1st June 2007, 05:03
you're sure that's the correct path to his game?

Sabber
1st June 2007, 12:36
yes it is.

KIMKo
6th June 2007, 09:20
I have the exact same problem!

You need half life 2 to run a mod

i only have hl2:dm and cs1.6 and cs:cz

what's the problem? it runs, i can see the hidden intro, but then it would crash!
i also can't see a sdk base in my tools section...


:EDIT

i think i know the problem. i have hl2:dm from this ATI promotion. it seems they don't want anyone to play mods with that.. only hl2:dm...
is there any way to fix that?

Gismya
8th June 2007, 17:09
To make things clear, you can't play hidden using the ATI "Free HL2:DM" promo?

SkaveRat
10th June 2007, 02:18
I have the exact same problem!

You need half life 2 to run a mod

i only have hl2:dm and cs1.6 and cs:cz

what's the problem? it runs, i can see the hidden intro, but then it would crash!
i also can't see a sdk base in my tools section...


:EDIT

i think i know the problem. i have hl2:dm from this ATI promotion. it seems they don't want anyone to play mods with that.. only hl2:dm...
is there any way to fix that?
ever tried the "Source SDK Base" solution?
Tutorial in the first post.

KIMKo
10th June 2007, 17:30
ever tried the "Source SDK Base" solution?
Tutorial in the first post.

Yeah sure! But the problem is, that steam won't let you install SDK base without having bought any source game. Since i only have HL2:dm from the promotion, i can't install SDK!!

I read somewhere, that this could only be fixed serverside. but i dont know how

Paegus
10th June 2007, 17:40
hl2dm IS a source game btw... it just doesn't come with the source sdk in your case.

you can use the steamappid 320 fix though and just make a desktop shortcut

or use this (http://forum.hidden-source.com/showthread.php?t=4849&p=96995)

KIMKo
12th June 2007, 16:23
hl2dm IS a source game btw... it just doesn't come with the source sdk in your case.

you can use the steamappid 320 fix though and just make a desktop shortcut

or use this (http://forum.hidden-source.com/showthread.php?t=4849&p=96995)

Dude believe me! I tried it all. You can make a new Steam account only with this promo version of hl2:dm and see for yourself. Well it doesnt matter to me anymore, since i bought a source game i can easily play it either with sdk or the 320 appid.

see you on the servers :)

iFr[i]T
17th June 2007, 20:04
I had the same problem than KIMKo
(SDK unavailable because the ATI promotion download doesn't furnish it)
so when I was doing your tutos to launch Hidden with HL2 : DM,
I had a pop-up message saying that HL2 was necessary to play mods.
(and the promotion doesn't permit us to download HL2...)

But, after some research,
I've found that I was able to launch Hidden thanks to HL2 : Lost Coast.
I copied the hidden directory in the HL2 : LC directory,
and made a new shortcut pointing on hl2.exe adding the "-game hidden" string,
and then I can play :]

I hope it will help some others players ^^
(and I'm sorry for my catastrophic english, huhu)

See you on the servers !

Raz-13
11th July 2007, 18:32
I can't Connect to the Master Server List to get a list of running servers. Nor can I run the tutorial, because it closes and says it could not run the authentication library. What's up?

Makaveli673
15th July 2007, 14:55
If you don't understand what hes trying to say visit this, my explanation's somewhere down there
HERE (http://forum.hidden-source.com/showthread.php?p=122341#post122341)

Solo
8th August 2007, 06:43
Makaveli673 you didnt add hidden after -game "C:\Program Files\Steam\steam.exe" -applaunch 320 -game hidden C:\Program Files\Steam\SteamApps\SourceMods\hidden

Makaveli673
22nd August 2007, 00:14
Makaveli673 you didnt add hidden after -game "C:\Program Files\Steam\steam.exe" -applaunch 320 -game hidden C:\Program Files\Steam\SteamApps\SourceMods\hidden

Yes i did

Paegus
22nd August 2007, 05:49
Yes i did

make sure you quoted the -game "path" as it has a space in it.

Aceed
7th January 2008, 10:27
I know this thread is quite outdated, but;
I get to the Hidden: Source menu loading, but just before the buttons are approximatley about to show, the game shuts down and Steam gives the error message that "Half Life 2 is required to play mods".
Is this a permanent fix against us HL2DM players, or is there some way to bypass it?

Paegus
7th January 2008, 12:00
edit the .../hidden/gameinfo.txt file from SteamAppId 215 to 320 or 340 or whatever hl2dm is. if it still errors then.. :(

Vox
22nd October 2009, 13:54
I know this thread is quite outdated, but;
I get to the Hidden: Source menu loading, but just before the buttons are approximatley about to show, the game shuts down and Steam gives the error message that "Half Life 2 is required to play mods".
Is this a permanent fix against us HL2DM players, or is there some way to bypass it?

I have the sam problem here it says Engine error:Half life 2 is required
to play mods.
I only have HL2: DM installed. Anyway to fix this?

EDIT: I have not paid for the the game i downloaded it via steam for free ...