PDA

View Full Version : Beta 3 Server Side Patch



MiasmicAnomie
11th May 2006, 14:50
There's a server side patch for Beta 3:

http://www.hidden-source.com/downloads/hidden-server-patch.zip (please mirror it if you want, etc)

This patch contains the following changes:

- The Headless IRIS issue is no more ( we added a pumpkin ... just kidding ;) )
- No Hidden with random select on is fixed
- Random select is much more fair
- This is the biggie - Mass timeout / mass client crash should no longer happen (there appear to be other bugs that will crash the client - this does not solve all client crashes - however, neither I nor the other server admins testing the patch have seen mass timeouts after applying the patch - there have been timeouts, but not en-masse)

There may be a couple of other minor things that I'm forgetting.

The .zip file has the hidden/bin/ directory structure, just stop, unpack it from the directory above your hidden directory, and start.

chilly
11th May 2006, 15:13
Any tips regarding whether its suitable for the pre-8th march srcds binaries?

~rolls it out on a test server anyway~

Thanks team!

/edit - Mirror up for those who get slow speed on that host. (Note, I've only got about 200gig of transfer to spare on this so dont rape my server TOO much :P )

Linkeh: www.primefarm.co.uk/stuffs/hidden-server-patch.zip

MiasmicAnomie
11th May 2006, 15:18
The patch is on the DEADCLAN servers, and we run the pre-8th March srcds so that we can have VAC.

I haven't seen any issues, and we've been running the patch for a bit to test it.

chilly
11th May 2006, 15:26
Well it killed my VAC.

Any chance I could get a tar of your /srcds/bin directory to compare to my files ? (assuming you run linux srcds)


/edit - hmmm, having restarted the server 6 times it now connects to VAC properly. It was every time before the patch, though. This VAC stuff is bizarre.

MiasmicAnomie
11th May 2006, 15:33
DEADCLAN runs on Windows, so I can't really help you there.

Other servers that I know are running the patch, and on Linux, are also VAC secure right now (I just checked). I think there's a link to the right srcds binaries in a thread somewhere - I'll have a look, you may want to as well. Edit: there's a link to a link in http://forum.hidden-source.com/showthread.php?t=3597&page=1 (second page)


Edited edit: Yeah. I've seen weird behavior like that on my linux box as well, before we'd released Beta 3 - this time it starts it secures fine, that time it starts and doesn't secure. It's really odd - but I don't think this patch to Beta 3 has anything to do with it.

Dead Inside
11th May 2006, 16:19
Mirrored at http://www.deadweb.co.uk/download/hidden/server/hidden-server-patch.zip

I've not seen it have any effect on VAC at all, VAC itself was funny recently, seemed to be down or something at one point, the server autosecured later so just a minor problem anyway. With the older binaries its usually fine, although in general takes two attempts at starting to get secure, it would again probably autosecure if i left it, i just preffer to be see it happen _

ThunderDan
11th May 2006, 17:41
Thanks for a patch.

K. GoBlin
11th May 2006, 18:15
So far, so good. Mani's back on my server and I haven't noticed any mass timeouts yet.

M_C
11th May 2006, 18:44
I'll be patching today, thanks porchy...

Merlin the Tuna
11th May 2006, 19:26
Nice to know that some progress is being made on the B3 bugs. Are we likely to see any client-side updates in the near future?

K. GoBlin
11th May 2006, 20:25
Sent an announcement to Mod HQ of the patch (hope you guys don't mind) so others might get the news.

detached
12th May 2006, 04:31
Got West Coast servers updated. Now to get the one in Beijing updated too.

Hope this helps.

Thanks Guys.

tcviper
13th May 2006, 23:23
What is the solution to that VAC thing then people? I mean how come they do not make other mods VAC secure anymore?

ThunderDan
14th May 2006, 00:45
That's a valve thing - no mod can fix that. To make your server VAC you need to roll back to pre March 8th. There's a sticky on this in the support forums.

CK*BLACKWOLF
18th May 2006, 23:52
Server only stays vac secured for about 15 seconds,since patch.
windows server.