PDA

View Full Version : Servers // Clients crashing like crazy



Payback
28th April 2006, 23:25
Origin, discovery, other maps
Timelimit: multiple servers, I assume default (?)
Conditions: Most seem to be at the end of the round, but occassionally mid round as well.

The client has crashed about 3 times in 30 minutes. A couple times when I crashed, some of the other people in the ventrilo server also reported that their client crashed as well. I also noticed the server seemed to have been flushed when I finished reloading.

Also, every server I join seems to crash after 3-4 rounds. Pigstick servers. I played on Thunderinnovations, Hidden Source beta 3 |PW| or some such, -={ASC}=- Hide and go f**k yourself, and the Miasma (sp?) one. Some of the crashes were end round and some were mid round.

M_C
29th April 2006, 00:14
Origin, discovery, other maps
Timelimit: multiple servers, I assume default (?)
Conditions: Most seem to be at the end of the round, but occassionally mid round as well.

The client has crashed about 3 times in 30 minutes. A couple times when I crashed, some of the other people in the ventrilo server also reported that their client crashed as well. I also noticed the server seemed to have been flushed when I finished reloading.

Also, every server I join seems to crash after 3-4 rounds. Pigstick servers. I played on Thunderinnovations, Hidden Source beta 3 |PW| or some such, -={ASC}=- Hide and go f**k yourself, and the Miasma (sp?) one. Some of the crashes were end round and some were mid round.
JDQC has crashed, once, so far, with a memory error, while full. I don't know what map or when during the map. :(

starstriker1
29th April 2006, 00:36
I haven't noticed anything myself.

Payback
29th April 2006, 00:40
Deadclan seems stable.

M_C
29th April 2006, 04:28
I just had my client lock and crash with a mem error too.

Faulting application hl2.exe, version 0.0.0.0, faulting module datacache.dll, version 0.0.0.0, fault address 0x00008a37.

MiasmicAnomie
29th April 2006, 06:02
M_C, can you compress and send me the .mdmp file? It should be in your hl2 dir (SteamApps/<yourlogin>/etc)

Hicks
29th April 2006, 13:40
yup, I had major problems yesterday with crashing aswell,

my client crashed about 8 times in 45 minutes, most of the time about 3 rounds after I joined a server... One time the whole pc crashed and i had to reboot...

Well I like the beta3 much, but I can't play it well, because I have to restart it all the time...

Skifer
29th April 2006, 13:59
I get loads of bugs on hidden too

edit°
29th April 2006, 14:28
My client has crashed about 10 times in the past 20 mins, Mainly on origin and mainly when I click to change the spec view to a new player/location. It was fine last night, its only today its been like this, I didnt have a single crash last night.

Sindri
29th April 2006, 14:38
My client crashed 2 times in a row playing on origin....
without any error messages or something

But no other bugs so far, nice work on b3

edit°
29th April 2006, 14:41
Happened again now, which means its happened on almost every map. Its a bit ****ing irritating because the tester version with the kit select crash didn't crash this often and the last tester sure as hell didn't either. Whatever it is, its happened somewhere between the latest tester version and B3.

Payback
29th April 2006, 18:16
Just client crashed on sewers after pressing M to load up the select menu.

tcviper
29th April 2006, 18:25
when are they going to fix these bugs? its crashing like hell for a lot of people!

M_C
29th April 2006, 19:24
M_C, can you compress and send me the .mdmp file? It should be in your hl2 dir (SteamApps/<yourlogin>/etc)
I usually delete those...let me check. I'll PM you a clicky if I find it. There may be 4 or so. Last night, I re-installed my AMD CPU driver and rebooted but I haven't checked for client crashes again, today, yet. The server, so far, has only crashed once. ;)

EDIT: 5, including one from the server. PM'ing ;)

Kitty_Loaf
29th April 2006, 19:26
i've only crashed... twice, and that's for playing around... 4 hours

Payback
29th April 2006, 20:26
Got this one while respawning. My screen flashed somewhere below the ground for a split second before it crashed. My buddy in ventrilo also crashed.

http://jaih.optus.nu/img/error.gif

M_C
29th April 2006, 20:57
Seems related. :(

ThunderDan
1st May 2006, 00:15
I compiled some server stats to compare my B3 servers to my B2a server.

B2a
Mani Admin
Stats from last 24 days before B3 released
16 Server Crashes
122 timeouts
262 Hours Playtime
4477 kills
0 Mass Timeouts

B3 Server 1
Pigstick Off Random Off
Mani Admin
Stats from 3 days since B3 released
35 Server Crashes
319 timeouts
20 Hours Playtime
2348 kills
17 Mass Timeouts

B3 Server 2
Pigstick On Random On
NO Mani Admin
Stats from 3 days since B3 released
16 Server Crashes
275 timeouts
28.5 Hours Playtime
3772 kills
17 Mass Timeouts

Now it might just be the crazy amout of trafic we are seeing from the new release that's causing these issues, but I feel the increased crashes and timeouts are B3 related.

From my logs nothing jumps out as oh that's what's happening. No particular map, no particular time in the map (I've even seen it occur twice in one map), anywhere from 2-8 players will timeout at once. As you can see ps, random, and even mani doesn't seem to have an effect.

This server runs fedora core 3, the rolled back linux release of srcds for vac authentication, P4 2.8Ghz HT, 1G memory.

I hope this info is helpful in tracking down the culprit to this bug.

edit: BTW If the devs would like a copy of the server logs from mass disconnects I can zip them up and send them to you. PM me

Reiter
2nd May 2006, 10:31
Going through those stats it seems that the mod is even more unstable with a plugin like Mani. Did you use any other plugins like Quakesounds or the like?

I also had another bug that I wanted to report that may be similar to the server/client crashing. All the time my client will crash if the hidden is killed within a radius of about 5-10 feet away from me. Any further and the client seems tolerable to it.

I killed the hidden tonight on a server from a respectable distance and wince like I have learned to do when it dies and found my client stayed stable. But, not for long. When the server went to do teamchanges (take everyone to IRIS and then put me on Hidden) I crashed. I tried rejoining the server to find it had crashed at the same time.

Talking to people in-game also yields that people have the hidden-dying crash across a broad range of cards that are both hardware and software dx9 or otherwise, although the crash is less frequent with dx9-related cards. Is there an in-between animation that relies on different shaders that may cause the crash when the hidden is up close and dies? I notice at some points when I crash and am looking at the hidden and he has uncloaked, the last frame I see is the default model pose for any model (hands out to the sides, standing upright).

Finally, I noticed something in the condump each time I start a game and I think it relates to the shader/window bug. Perhaps you have seen it, perhaps it is intentional. Take a look:

Condump 1:

Game.dll loaded for "Hidden : Source B2B"
maxplayers set to 9
Heap: 256.00 Mb
Parsed 23 text messages
Couldn't find custom font file 'resource/cour.ttf'
Hud element 'CHudMaterial' doesn't have an entry 'HudMaterial' in scripts/HudLayout.res
joystick found
execing config.cfg
Can't use cheat cvar cam_command in multiplayer, unless the server has sv_cheats set to 1.
1 CPU, Frequency: 2.8 Ghz, Features: GenuineIntel SSE SSE2 MMX RDTSC CMOV FCMOV
execing valve.rc
Network: IP 192.168.0.102, mode MP, dedicated N, ports 27015 SV / 27005 CL
--- Missing Vgui material vgui/servers/icon_secure_deny
Connecting to 72.232.107.14:24104...
Connected to 72.232.107.14:24104

Hidden : Source B3
Map: hdn_executive
Players: 8 / 9
Build 2707
Server Number 174
Begin loading faces (loads materials)
End loading faces (loads materials)
CMaterial::LoadVMTFile: can't open "materials/models/manor/hr_model_teaurn_earlgrey_dx7.vmt"
CMaterial::PrecacheVars: error loading vmt file ls/manor/hr_model_teaurn_earlgrey_dx7 for models/executie/hr_model_teaurn_earlgrey
Initializing renderer...
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Warning: using WorldTwoTextreBlend on a non-displacement surface (material: nature/blendgrassgravel002a). Support for this will go away soon.
Error: Material "engine/occlusionproxy" uses unknown shader "Occlusion"
Connected
Connected
] condump

Condump 2

Game.dll loaded for "Hidden : Source B2B"
maxplayers set to 9
Heap: 256.00 Mb
Parsed 23 text messages
Couldn't find custom font file 'resource/cour.ttf'
Hud element 'CHudMaterial' doesn't have an entry 'HudMaterial' in scripts/HudLayout.res
joystick found
execing config.cfg
Can't use cheat cvar cam_command in multiplayer, unless the server has sv_cheats set to 1.
1 CPU, Frequency: 2.8 Ghz, Features: GenuineIntel SSE SSE2 MMX RDTSC CMOV FCMOV
execing valve.rc
Network: IP 192.168.0.102, mode MP, dedicated N, ports 27015 SV / 27005 CL
--- Missing Vgui material vgui/servers/icon_secure_deny
Connecting to 72.232.107.14:24104...
Connected to 72.232.107.14:24104

Hidden : Source B3
Map: hdn_origin
Players: 9 / 9
Build 2707
Server Number 175
Begin loading faces (loads materials)
End loading faces (loads materials)
CMaterial::LoadVMTFile: can't open "materials/models/manor/hr_model_teaurn_earlgrey_dx7.vmt"
CMaterial::PrecacheVars: error loading vmt file tls/manor/hr_model_teaurn_earlgrey_dx7 for models/executivehr_model_teaurn_earlgrey
Initializing renderer...
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Attempting to bind a texture to an invalid stage (2)!
Error: Material "engine/occluionproxy" uses unknown shader "Occlusion"
Connected
] condump

(Makes me wonder if the occlusion shader is causing the crashes)

Hope it helps

M_C
2nd May 2006, 18:01
We know what's causing the crashes and they're working on it. My b3 server seems to crash 1x/day and clients crash/timeout when triggered by the bug. Once it's fixed, things will settle down.

=AWOL=Manoe
2nd May 2006, 18:45
Its very odd. My server crashed like 4 times last night. Then it would play just perfect for a couple hours. I don't get it. Either they are map glicthes or its certain players crashing the server.

Reiter
2nd May 2006, 23:35
We know what's causing the crashes and they're working on it. My b3 server seems to crash 1x/day and clients crash/timeout when triggered by the bug. Once it's fixed, things will settle down.

Do they have an eta on the hotfix? Not that I am nagging or anything.

M_C
2nd May 2006, 23:41
No eta and what they thought was causing it may not be the case now according to one of the other threads. I'm sure we'll know when they know. *shrug*