PDA

View Full Version : Settings won't be saved



ezee
20th April 2006, 10:57
Hello folks.

I installed The Hidden - Source about two weeks ago and since then my graphical settings (resolution, gamma, texture quality, model quality and so on) won't be saved. I may set them while in the game but as soon as I exit and restart everything is reset to default values (which means resolution is 800x600, gamma is 50%, texture and model quality are middle and so on). I already checked if any .cfg is write-protected but they are all writable.

I start the game with following parameters:
-heapsize 256000 -console -dxlevel 81

I also use an autoexec.cfg with following content:

// key bindings
bind "\" "toggleconsole"
bind "kp_plus" "admin"
bindtoggle "p" "cl_showfps 2"

// performance tweaks
cl_forcepreload 1
sv_forcepreload 1
cl_smooth 0
cl_ragdoll_collide 1
cl_hvision 0
r_fastzreject -1
r_decals 1000
r_maxmodeldecal 25
r_waterforceexpensive 0
mat_compressedtextures 1
mat_bumpmap 0
mat_specular 0

Does anybody have a clue what's happening? Thanks in advance.

M_C
20th April 2006, 17:29
Hello folks.

I installed The Hidden - Source about two weeks ago and since then my graphical settings (resolution, gamma, texture quality, model quality and so on) won't be saved. I may set them while in the game but as soon as I exit and restart everything is reset to default values (which means resolution is 800x600, gamma is 50%, texture and model quality are middle and so on). I already checked if any .cfg is write-protected but they are all writable.

Does anybody have a clue what's happening? Thanks in advance.
Make sure your cfg dir and files are NOT read only. *shrug*

ezee
20th April 2006, 17:50
In fact there is a mark in front of the write-protection option of the cfg directory. But it's not a check mark, it's a blue square. Actually every single directory, including the Steam directory itself, has this square in front of the write-protection option. I may uncheck it and click on OK but after re-opening the properties it's back. How can I fix it?

M_C
20th April 2006, 18:06
In fact there is a mark in front of the write-protection option of the cfg directory. But it's not a check mark, it's a blue square. Actually every single directory, including the Steam directory itself, has this square in front of the write-protection option. I may uncheck it and click on OK but after re-opening the properties it's back. How can I fix it?
Try logging on as Administrator. If it's not checked it shouldn't be read only but go inside the cfg dir and check the config.cfg to see if it's read only or just delete that file and next time you start it'll give you a default one.

ezee
25th April 2006, 10:48
Alright, I upgraded my memory and bought a new graphics card and now the problem is gone. Strange. :D

M_C
25th April 2006, 17:10
As long as it's fixed...

Kill you later! ;)