PDA

View Full Version : Some Graphic Manipulation?



Viper114
27th March 2006, 05:38
Ok, so I've managed to get Hidden to run on DirectX 8.1 with...playable framerates. Basically, the game will run anywhere from 10 to 25 FPS, depending on what's on screen. And I've been doing somewhat better now that I can see the Hidden like I should.

But, I want to try and get more FPS, and I think I have a hypothesis on how that can be done.

Is there any way to FORCE the game to run the Texture Detail at DX Level 7.0, while leaving other aspects in 8.1? I figure the biggest things that cause FPS drops are the Water (which I rather not change since I think the Hidden is tied to water appearance) and the environmental texturing. If I can force the game to run the texture detail at a lower DX level, I should be able to get the better FPS that I get when running the whole game in 7.0 (or, partly, except for water and the like) than I get at the moment.

Is it possible?

Payback
27th March 2006, 05:51
Have you tried turning bump mapping off?

in console type

mat_bumpmap 0

Viper114
27th March 2006, 06:08
Well, that actually worked. The textures do look like they're running on 7.0, but I can still see the Hidden as if he were in 8.1. And the FPS jumped to running about DOUBLE the original amount, going anywhere from 20 to 40+ FPS depending on what's on screen. By god, I think I've found the perfect combination!

...well, almost perfect. For some weird reason now, it looks like that my characters hands and weapons were made out of chrome metal, all shiny and metallic like. But, I can live with it.

Thank you greatly for that cvar. I desperately needed it. Now I can play Hidden the way it's meant to be played.

Payback
27th March 2006, 06:27
Keep an eye on this thread.

http://forum.hidden-source.com/showthread.php?t=3542

Viper114
27th March 2006, 15:09
So, if I use

mat_bumpmaps 0

and then use

mat_specular 0

I should be able to have the simple textures, but lose the chrome effect on the arms and weapons?

Payback
27th March 2006, 15:11
Give it a shot.

Dragon_Mech
27th March 2006, 15:38
To run textures in a lower resolution use this command in your autoexec file:

"mat_picmip"


It can be set from 0 to 4. 0 is high texture quality, 1 is medium, 2 is low, and 3 & 4 are even lower than that.

With mat_bumpmap and mat_specular set to 0, and mat_pcmip set to 3 and higher, the game should run significantly faster.

Viper114
27th March 2006, 16:32
Well, I used those two commands in my CFG file that I have running at the Hidden:Source launch command line, and I managed to get the framerate desired with the chrome effect of bump-mapping off removed. And the Hidden still looks like he should. Awesome.

I might try that picmip option too to experiment, and see how well it works out, or if it's actually needed or not.

As a side note, since this little tweaking, my game as an I.R.I.S member has improved by HUGE margin. :D

M_C
27th March 2006, 16:37
Well, I used those two commands in my CFG file that I have running at the Hidden:Source launch command line, and I managed to get the framerate desired with the chrome effect of bump-mapping off removed. And the Hidden still looks like he should. Awesome.

I might try that picmip option too to experiment, and see how well it works out, or if it's actually needed or not.

As a side note, since this little tweaking, my game as an I.R.I.S member has improved by HUGE margin. :D
When you're all done tweaking, you might want to start a new thread explaining all of the settings you tried and what you use to get better performance for your series of vid card. It might even get stickied. ;)

edit°
27th March 2006, 17:18
A fine idea, theres been so many folks put off of the hidden because they didn't have the know how to deal with this. Duh eet!

starstriker1
28th March 2006, 21:21
Just a note: water detail is not tied to the hidden shader, only the shader settings are. Feel free to turn it to nothing.

Chas0r
28th March 2006, 21:33
I didn't notice that this cvar was lissing in you list (Tweaking thread). I'm using this setting since b2. (no bump, no specular)
For other steam games, dont forget to add stuff like
mat_fastspecular 0
mat_bloom 0
mat_normals 0
mat_normalmaps 0
mat_diffuse 0 //usually causes screen to be black

Gusdor
28th March 2006, 21:38
You get that "chrome" effect because the masking of the environment map (reflection caused by the cubemap renders) is tied to the normal / bumpmap textures. Taking away processing of the bump maps takes away this mask and therefore leaves the environment map unmasked. I thin kthere is a way of inverting the mask so that this doesnt happen but its not really worth doing