PDA

View Full Version : Linux, b2a and VAC?



Danni
20th March 2006, 02:30
I am running a linux server for our clan buddies and thinking about a second, but we have this strange issue. Our servers are not running VAC2.

Now the odd thing here is that if i run this...


./srcds_run -console -port 27015 +ip 70.xx.xx.246 +maxplayers 9 -game hidden +map hdn_traindepot

We have no VAC2 and the server is in insecure mode. But if i run this:


./srcds_run -console -port 27015 +ip 70.xx.xx.246 +maxplayers 9 -game hl2mp +map dm_lockdown

It runs secured (just not the hidden).

The only odd thing i see on the console is


Adding master server 68.142.72.250:27011
Adding master server 207.173.177.11:27011
Connection to Steam servers successful.
VAC secure mode disabled.


Odd eh? Anyone have this issue or any ideas? It must be something in teh configuration so i am checking it all over now.

khu
20th March 2006, 11:58
I don't know anything about running servers and a lot of the team is away. If you don't get an answer from someone else, wait until they get back from GDC, ok?

K. GoBlin
20th March 2006, 13:57
Everyone seems to have their own opinion on this subject since no one can ever get an official answer from Valve, but from what I can gather (and from personal experience, since I have the same issue on my mod-based servers running Win2k3) it's random which servers will actually truely authenticate to the VAC servers. I get the same exact message on my non-CS/DOD servers (those authenticate just fine).
Some people claim you can get your server to enable VAC if you just keep restarting it, but I haven't found that to be true.

Edit: I use Steambans as an alternative anti-cheat resource. It's actually, in the long run, a better way of handling hackers, but unfortunately it won't present your server as being secure when browsing servers in the Steam menu.

Donat
20th March 2006, 15:05
VAC wont stop people from not updating / down grading their drivers so they have black hidden syndrome! And if some one speed hacks its easy to tell, aim bot not so much though.

K. GoBlin
20th March 2006, 15:10
Problem with not VAC securing your server is that a lot of people won't even play on servers that aren't VAC secured. I don't blame them. At a glance, people might assume that the admins aren't proactive about dealing with hackers. I'm hoping I'll be able to secure my servers with the next Steam DS update.
I guess that's my best advice to you Danni, wait til the next update and see if you can get it to work then.

Donat
20th March 2006, 15:26
smart people will just tell you one thing about vac that i hear alot

"It dosent work"

well enough any way.

K. GoBlin
20th March 2006, 15:36
Heh, well unfortunately there aren't many smart people playing games these days so it's best to do what you can to make them think VAC is doing it's job and keeping them safe. If I could get the server to just show a little VAC symbol next to my servers and not be VAC secured, I would. ;)

Danni
21st March 2006, 02:51
smart people will just tell you one thing about vac that i hear alot

"It dosent work"

well enough any way.

Go play on a VAC2 secured server with a public cheat see what happens about a week or two weeks later.

VAC2 works just fine, I know three people who have been banned and can no longer play on secure servers. And as the gentleman above mentioned, many people (me included) refuse to play on an unsecured server.

Yes there are cheats which get around VAC2 and my solution is to build redundancy. On our CS/DOD servers we use Steambans, VAC2, HLGuard, CVarRules and my own system called AimWarn. With all these systems in place I am proud to say I have seen only one cheater on our DOD server within an entire year and he was VAC2 banned a week later.

I just need VAC2 to work on teh Hidden now. :)

Demented
21st March 2006, 03:04
VAC just isn't enabled for Hidden by default, is all. How to enable it is the question. Theoretically it might have something to do with the sv_secure cvar, though I haven't heard of great success with it.

Donat
21st March 2006, 03:56
i like how u said "public" cheat ;)

most hackers that get around VaC make their own i hear. thats why people compalin and whine that it dosent do any thing. Yea, it will cach and ban most hackers, just saying.

K. GoBlin
21st March 2006, 05:02
VAC just isn't enabled for Hidden by default, is all. How to enable it is the question. Theoretically it might have something to do with the sv_secure cvar, though I haven't heard of great success with it.
The secure cvar is enabled by default (has been for quite some time now). You actually have to change the startup command to *disable* VAC. The problem isn't enabling it, it's some sort of communcation/authentication to the VAC servers. I've searched high and low for an official answer from Valve, even an "We don't know, sorry." yet I've found nothing. I was hoping this recent update tonight would've changed something, but unfortunately the problem remains.

deadscott
21st March 2006, 09:51
Vac is controlled in the command line. To enable Vac in HS add -secure to your command line.

Example:

./srcds_run -console -port 27015 +ip 70.xx.xx.246 -secure +maxplayers 9 -game hidden +map hdn_traindepot

K. GoBlin
21st March 2006, 13:52
Just FYI, you no longer have to add -secure to your command line to enable VAC on your dedicated servers. It's enabled by default. You can add -secure to your startup command all day long but it's not going to make a difference whether or not your server is going to actually connect/authenticate to the VAC servers unfortunately. :(

deadscott
21st March 2006, 14:07
It's the only way I can get it to run with HS. I can only give information, what you do with it is up to you.

Sir Wankus Magpie
21st March 2006, 17:13
hes got a point...might as well try it the -secure ;)

K. GoBlin
21st March 2006, 19:07
Very true. Dedicated servers, unfortunately, aren't an exact science. I can't get my DOD server to enable VAC unless I specify the IP in the command line. And nope, no -secure. Who knows why? :confused:

Danni
22nd March 2006, 00:13
I am already way ahead of you and already tried +secure and -secure on the command line way before I posted. I cannot see an obvious solution hence I posted here.


Very true. Dedicated servers, unfortunately, aren't an exact science. I can't get my DOD server to enable VAC unless I specify the IP in the command line. And nope, no -secure. Who knows why? :confused:

That is a different reason. It is because something is already bound to the VAC2 port. When you specify the IP, you specify one which does not have that port already bound. The default address I think is ADDR_ANY which means all addresses on the machine.
To fix that you would add -sport followed by a free port number to the command line.



i like how u said "public" cheat ;)

most hackers that get around VaC make their own i hear. thats why people compalin and whine that it dosent do any thing. Yea, it will cach and ban most hackers, just saying.

True it gives them trouble, but they can get caught. If Valve has any sense (which they do) they would have tripwires in VAC2 which would alert them to certain misdoings such as a debugger attaching, memory alteration/corruption etc. When this happens, they grab a snapshot of whatever did it and look at it in more detail.

I in fact have some nice code which detects debuggers, breakpoints, VMWare and such. :)

K. GoBlin
22nd March 2006, 02:01
Nope, I tried -sport as well back when I was struggling with my DODS serer. It's just more Valve DS randomness. Nothing worked until just out of sheer desperation, I put in +ip xx.xxx.xxx.xxx and it connected. After all the nonsense I've been through with my other servers, I'm starting to think it was just coincidence it decided to work the same time I tried putting in +ip.