PDA

View Full Version : Memory could not be "read" error



Veloxio
9th August 2013, 17:26
Hullo all.
Had this problem for a few years now, though the game worked flawlessly for quite a while before this showed up (for what seems to be no reason, to my limited knowledge.

Basically, on a fresh install, I can play the game for one session (as many servers/maps as I like), until I exit or the game crashes for some reason.
Upon the second startup, while loading the main menu, I get the following error:

The instruction at "0x241fa597" referenced memory at "0x0f3d85e0". The memory could not be "read".

I've tried various fixes (the stickies and search results here and elsewhere; e.g. the steam shortcut, running with HL2, HL2DM, applaunch and appid changed, etc.) unfortunately to no avail.
The only partial solution I've found is to launch the game with -nosound, which allows me to get into the menu, and even play, albeit without sound.

Any insight would be greatly appreciated.

Linked here (http://sharetext.org/eZPT) is my dxdiag, if that helps.
Download (https://www.dropbox.com/s/3d6id06gp8as3ei/DxDiag%209%20August%202013.txt), if desired.

Paegus
10th August 2013, 05:44
If it works with sound disabled, then perhaps your sound hardware/drivers is the issue?
Do other source mods work? like NeoTokyo?

Veloxio
10th August 2013, 22:40
Yes, they do. Forgot to add that I did try updating my sound drivers, though haven't gotten a chance to check if that fixes yet.

Edit: Doesn't work after updated sound drivers.

Paegus
11th August 2013, 12:44
Try deleting the .../steam/steamapps/sourcemods/hidden folder and re-install using the dedicated server .zip package not the normal .exe one.

Veloxio
11th August 2013, 22:21
No luck. Just like the installer, it runs once and crashes afterwards.

Could it have something to do with creating soundcaches? I notice there's a short period of creating soundcaches or somesuch when I first run, but the game crashes before it appears on the next startups.

Paegus
12th August 2013, 06:52
Honestly i've no idea...

Veloxio
13th August 2013, 22:16
Alrighty. I appreciate the help; I'll likely try Steam forums or elsewhere to see if there's any solutions, otherwise I'll assume it actually is a memory error (the computer is a few years old, after all).

Thanks.