PDA

View Full Version : Cant launch the game / HL2.exe crash



Kira523
26th December 2012, 22:25
Ok so i know this is gonna sound very noobish, and i apologize if theres already a thread for this, but I cant launch the game in steam. I bought half-life 2 and downloaded the installer for the hidden. It shows up on my steam account, but when i go to click play it wont launch the game. Can someone please help me out here.

The.ViruS
26th December 2012, 22:37
You need Source SDK Base 2006 installed.

Added by Paegus on 17 June 2013:
Make sure you can run the Source SDK Base 2006 (steam://run/215) > Video Stress Test, which can be found under the Tools section of your Steam client or by clicking that link...

If you cannot run that please try this (http://forums.steampowered.com/forums/showthread.php?t=1100021) or contact Steam support for help. We cannot assist further and making a new thread about it will net you a link to this Sticky thread.

If you can run the Source SDK Base 2006 then:

Try adding -autoconfig to the launch options under Games > Hidden Source > Right-Click > Launch Options

Kira523
27th December 2012, 01:36
I thought all i needed was half-life 2, steam and the hidden source installed. Do I have to download that separately?

The.ViruS
27th December 2012, 11:13
Yes I believe so.

Kira523
28th December 2012, 18:59
ok so where would i find that? because when i searched for it on google it said that source sdk 2006 is the engine that half-life 2 and CS:S run on already

Ging
29th December 2012, 00:03
It's in the "tools" area of your steam library.

Kira523
30th December 2012, 02:32
Ok thanks so much Virus and Ging

WarriorMonkColm
2nd January 2013, 13:22
Hi, I'm having the same issue and I was wondering if you could tell me where I could access the tools section of my library, never really used mods like this through steam before :P

ado921
2nd January 2013, 16:13
I have made a few screenshots to show where and how you can access your tools and install the required Source SDK engine.

The Where: http://gyazo.com/631a0b543b93e276b0732928f5bbbb4f

The How: http://gyazo.com/1a1f981682a477ec7fa51e6159bc4c77

This is all done from starting at the Steam library.

EDIT: To clarify in case you somehow are confused as to which engine is being pointed at (the arrow obscured it, my error)
You will need to install Source SDK 2006

Platinumwings
5th January 2013, 22:47
Thanks a bunch was really frustrated as to why this wouldnt work.

1ChanceGaming
15th January 2013, 02:33
I would like to let you know that I specifically created this account on the forums to thank you for this post :)

Ticky
28th January 2013, 16:03
Yes, thank you very much. I was very confused at first.

bronzebacon
12th February 2013, 08:45
additional thanks for this thread. I was pulling out my hair going WTF

awesome703
4th May 2013, 02:05
hey well that worked but now it says preparing to launch and nothing happenes

dhaley6
15th May 2013, 02:09
I am not able to play the game either. I keep getting the "hl2.exe has stopped working" as soon as the game launches. I have the game downloaded, i have sdk 2006 installed. And i have restarted steam and done the "-dxlevel 80" launch option. and i am about to throw my computer across the room. I have tried EVERYTHING multiple times and i cannot get it to work.
PLEASE HELP ME!!!

ado921
15th May 2013, 02:54
Right click Source SDK 2006, click on properties, and go to local files. Verify Integrity of Tool Cache. If that doesn't work try reinstalling it.

Paegus
15th May 2013, 05:53
Can you launch and play the source SDK base 2006 engine/tech demo?

dhaley6
16th May 2013, 00:53
I tried this and it did nothing. I have reinstalled it at least 6 times -_-.

dhaley6
16th May 2013, 00:54
No when i launch it, i get to to the Valve splash screen and then after that it just crashes and says "hl2.exe has stopped working" but source base 2007 works fine?

dhaley6
16th May 2013, 00:55
No when i launch it, i get to to the Valve splash screen and then after that it just crashes and says "hl2.exe has stopped working" but source base 2007 works fine?

Paegus
16th May 2013, 08:03
Then I'm afraid your problem lies with the source sdk base 2006.
Have you made sure to delete the 2006 local game content AND the .../steam/steamapps/ACCOUNT/source sdk base 2006/ folder?

If so then I'm stumped. Post a support query at steam and see what they say, if anything.

dhaley6
20th May 2013, 01:33
Then I'm afraid your problem lies with the source sdk base 2006.
Have you made sure to delete the 2006 local game content AND the .../steam/steamapps/ACCOUNT/source sdk base 2006/ folder?

If so then I'm stumped. Post a support query at steam and see what they say, if anything.

Well... this sucks lol. Half life 2 is working fine? just not sdk source base 2006. 2007 works. Why me?! :(

Glitchhunter96
27th May 2013, 03:13
you could try this.
http://forums.steampowered.com/forums/showthread.php?t=1100021

Rodas
30th May 2013, 19:59
Same problem dhaley

AloneMentos
18th June 2013, 22:01
yea so i posted this thread here -> http://forum.hidden-source.com/showthread.php?11663-Hy-I-can-t-get-the-game-to-start

The game just crashes, after i made the post i poked around the forum and followed the steps bellow

You need Source SDK Base 2006 installed.

Added by Paegus on 17 June 2013:
Make sure you can run the Source SDK Base 2006 found under the Tools section of your Steam client.

If you cannot run that please try this or contact Steam support for help. We cannot assist further and making a new thread about it will net you a link to this Sticky thread.

If you can run the Source SDK Base 2006 then:

Try adding -autoconfig to the launch options under Games > Hidden Source > Right-Click > Launch Options
Last edited by Paegus; Yesterday at 15:55.



And i updated the thread i opened saying that the instructions from Paegus didn't work ( don't know why the reply isn't there), the source sdk 2006 keeps crashing after i install it
I even followed steps here for the sdk 2006 problem http://forums.steampowered.com/forums/showthread.php?t=1100021 in Gaining ownership to the file, still nothing.

I don't know what else to do, i tried everything that you guys said, and still nothing so far :/

i tried downloading the sdk 2007 thingy, that one works but you guys clearly said 2006...so i`m waiting for a reply or something :/ really wanna play the game, looks awesome. please help :)

AloneMentos
18th June 2013, 22:02
yea so i posted this thread here -> http://forum.hidden-source.com/showthread.php?11663-Hy-I-can-t-get-the-game-to-start

The game just crashes, after i made the post i poked around the forum and followed the steps bellow

You need Source SDK Base 2006 installed.

Added by Paegus on 17 June 2013:
Make sure you can run the Source SDK Base 2006 found under the Tools section of your Steam client.

If you cannot run that please try this or contact Steam support for help. We cannot assist further and making a new thread about it will net you a link to this Sticky thread.

If you can run the Source SDK Base 2006 then:

Try adding -autoconfig to the launch options under Games > Hidden Source > Right-Click > Launch Options
Last edited by Paegus; Yesterday at 15:55.



And i updated the thread i opened saying that the instructions from Paegus didn't work ( don't know why the reply isn't there), the source sdk 2006 keeps crashing after i install it
I even followed steps here for the sdk 2006 problem http://forums.steampowered.com/forums/showthread.php?t=1100021 in Gaining ownership to the file, still nothing.

I don't know what else to do, i tried everything that you guys said, and still nothing so far :/

i tried downloading the sdk 2007 thingy, that one works but you guys clearly said 2006...so i`m waiting for a reply or something :/ really wanna play the game, looks awesome. please help :)

ratchetclan4
20th June 2013, 00:03
Problem may be to do with WMI, i reinstalled windows using an upgrade install and i still cannot run the game.
what graphic cards are we all using?
i have an ati 7950
this might be a problem with ATI Cards

rockbotjake
21st July 2013, 04:26
hey i tried doing the same thing but keeps saying that its busy

rockbotjake
21st July 2013, 04:28
hey i tried doing the sdk thing but it keeps saying that its busy

NiceSpirit
4th August 2013, 04:24
Okay, I have had a problem for about a couple days now. I am able to start up the hidden source mod easily and with no hassle but when i wish to join a server I receive a HL2.exe crash error right when i get to the MOTD. Please help :confused:

udarz
30th August 2013, 13:15
So for like a week now I have the same problem, it occured when I changed my setting to the max. And everytime I start up the game 1 10th of the screen is just cut off and replaced with my background image and just craches. Nothing else happends after that it just return to what ever I had opened and pretends like I never started the game :/ . I tried reinstalling half life 2, sdk 2006/2007 ,The Hidden I even removed the Hidden files from my steam mods folder and replaced it with my brother his files, but still the same stupid issue.

I hope you guys can help me with this problem,

Greetings,

Udarz

ado921
30th August 2013, 21:34
Open up the launch options for the game and put -autoconfig

udarz
31st August 2013, 12:08
Open up the launch options for the game and put -autoconfig

Thank you so much, you are my HERO!

Bobmakeled
6th October 2013, 22:03
Virus i have tried most of the stuff to fix the hidden not starting up, and none of it works D:i have tried setting the launch options, reinstalling source SDK base 2006 but still won't work. Please Help!

Paegus
7th October 2013, 12:15
If you cannot run this (steam://run/215/) then your Source SDK Base 2006 is broken and you're plain out of luck. Hidden:Source will not work.

Feel free to hammer on valve's door about the Source SDK Base 2006 not working through...

TwoTails
15th March 2014, 06:31
If you cannot run this (steam://run/215/) then your Source SDK Base 2006 is broken and you're plain out of luck. Hidden:Source will not work.

Feel free to hammer on valve's door about the Source SDK Base 2006 not working through...

so, there is NOTHING anyone can do about it?

what if someone who can get Hidden: Source working puts up a download for their old SDK copy?

cauemd
3rd September 2015, 17:19
Found something that fixed the crashing at startup problem(at least here). Neither The Hidden or Source SDK Base 2006 were running on my pc, so after searching the interwebs for a while, I found that changing the steam language to "English" could solve the problem. And so it did. I had disabled Steam community while in game prior to that, don't know if it was just the language change or both the language and the in game steam community thing.