PDA

View Full Version : Was there ever a solution to the master server list?



Kin2InuYasha
9th November 2012, 09:54
Was there ever a solution for my linux server not showing up in the master server list? I know that this,


//************************************************** ************************************************** ******
// Master Server Settings
//************************************************** ************************************************** ******
sv_master_legacy_mode 0 // Disable lagacy mode, since steam master servers won't support it anymore.
heartbeat // Send heartbeat that this server is ready. Should be the last line of the config.
//************************************************** ************************************************** ******

works with a windows server, which is what I've been running, but I wanted to move to a linux machine. Every flavor, and every different machine I try will not display my server on the master server list with linux.

Like I said, I've been using a windows machine with the above code in my server.cfg and it works beautifully, it just doesn't seem to work for me under linux. Have there been any new developments?

Thanks.

Paegus
9th November 2012, 10:11
Could try asking the owners of People that Game (http://forum.hidden-source.com/showthread.php?11219-People-That-Game-Hidden-Source-TeamSpeak-3) or AteaMD (http://forum.hidden-source.com/member.php?6311-Sparks) as they seem to be running Linux based servers.

J Wall
9th November 2012, 16:13
I'm not sure what the problem could really be, as that is what the PTG servers are using.

Kin2InuYasha
9th November 2012, 19:31
Okay, I'll try asking one of them. I guess it's just a problem with my network. I find it weird that it's OS sensitive though.

Thanks for the quick responses.

Sparks
10th November 2012, 07:25
Replied to your PM.

o_O
10th November 2012, 09:27
// Master servers
//setmaster add hl2master.steampowered.com:27011
//setmaster add hl2master.steampowered.com:27015
//setmaster add 08.64.200.39:27011
//setmaster add 208.64.200.39:27015
//setmaster add 208.64.200.118
//setmaster add hl1master.steampowered.com
//setmaster add hl2master.steampowered.com:27011
//setmaster add 72.165.61.136:27010
//setmaster add 68.142.72.250:27010
//setmaster add 207.173.177.12:27010
//setmaster add 207.173.177.11:27010
//setmaster add 72.165.61.189:27010
//setmaster add 69.28.151.162:27010
//setmaster add 195.149.21.9:27010
//setmaster add 65.73.232.251:27040
//setmaster add 65.73.232.253:27040
//sv_master_legacy_mode 0
//heartbeat


setmaster remove hl2master.steampowered.com:27011
setmaster remove hl2master.steampowered.com:27015
setmaster add hl2master.steampowered.com:27011
setmaster add hl2master.steampowered.com:27015


Works for me (Linux)

Kin2InuYasha
14th November 2012, 17:21
Works for me (Linux)

I don't think it would matter, but may I ask which distro you're using? I'm using Debian personally. But the distro shouldn't have anything to do with a donkey turd should it?

Kin2InuYasha
13th December 2012, 01:09
Well, I don't know if it matters now, but I thought I'd post a solution I found anyways.

I've tried Fedora, CentOS, Debian, Gentoo, Arch and other flavors as a linux server host.

The ONLY one that seems to work properly for me is Ubuntu. I have no idea what the differences are, I did the EXACT same setup for all of them.

Fedora and CentOS would run the server, but wouldn't seem to show up in MSL, lan or favorites. Gentoo Debian and Arch would display the servers in lan and favorites but not on the master server list.

Along with

//************************************************** ************************************************** ******
// Master Server Settings
//************************************************** ************************************************** ******
sv_master_legacy_mode 0 // Disable lagacy mode, since steam master servers won't support it anymore.
heartbeat // Send heartbeat that this server is ready. Should be the last line of the config.
//************************************************** ************************************************** ******

Ubuntu seems to work just as it should. While I'd prefer a distro a little lighter than Ubuntu, it seems to work.

Just thought I'd let you guys know, or anyone running into the same thing.

Thanks.

Kin2InuYasha
13th December 2012, 21:44
I apologize for posting so many times, but I believe I've managed to work everything out.

To my extreme embarrassment, I'd like to report that you can disable the FIREWALL and allow the servers to be seen on Lan and Favorites. I can't believe I passed up this very simple conclusion on most of the Distro's.

It does not, however, fix the server not showing up on master server list. For distro's that that come with SELinux, setting the permissions to passive allow's the server to show up on MSL for some reason.

This will be my last post in this thread, I've been fighting with it for a while and Just wanted to let anyone who may come across the same problem know.

Thanks again.

johnnrandy
19th December 2012, 05:26
I had recently experienced this. Program runs perfectly but server not showing in Master List , It will happen due to the problem raised by installation process , the connection between LAN and WAN are connected in correct way, outside NAT problems , the connection between the ports will properly connected. once go through these points and check it ,you find a solution for this problem. Hope you will find the solution soon.