PDA

View Full Version : Client crash on player spawn



sqwishy
2nd October 2012, 04:16
I've set up two dedicated servers and, in both cases, clients would crash as soon as they tried to spawn. The crash would occur in the datacache.dll module.

The first server was on a 64bit linux machine. The second was on my 64bit windows 7 machine, but using a 32bit srcds as far as I can tell.

Both have the 4b and the hotfix installed with episode1 as the base and are new srcds installations.

The problem did not occur on LAN when I created a listen server.

I've already searched this forum and I haven't found anything that helps. Any suggestions?

Sniper
2nd October 2012, 04:40
Was it on a custom map?

sqwishy
3rd October 2012, 00:26
No, I tried hdn_highrise as well as hdn_docks or something and both had problems except when using a listen server.

Paegus
3rd October 2012, 05:42
Do you use the internet server to create the LAN server just with sv_lan 1 or are you using your normal game client?

perhaps something is wrong with the server installation. Try re-downloading the hsbfull 4b installation package (and the 4b1 hotfix) and reinstalling it.

Also try -verify_all on the dedicated server package?

sqwishy
4th October 2012, 14:18
I used the game client for the LAN server. I installed the dedicated server twice, it'd be unlikely that some sort of fluke caused the same symptoms in both cases.

I downloaded an archive the dedicated files again, their md5 matches the archive I used for the two servers I set up.

Edit: And I think I forgot to mention that I've tried playing on online servers, and I can spawn just fine. So I don't think there's anything funky with my client.

sqwishy
13th October 2012, 22:23
Bump? ._.